Clear-Com Solutions  
Solution 1397 : Wireless: Are Drake PD2202 beltpacks are compatible with latest version of FreeSpeak-20 base stations?
 
Question:  Do you know if old the Drake beltpacks are compatible with latest version of FreeSpeak-Base station? firmware.






















Answer: 
Yes, the old PD2202 beltpacks are fine to operate with the current base-station and software. You will need to upgrade your beltpack software for correct operation. This process is detailed in the CellCom/FreeSpeak upgrade manual.
http://www.clearcom.com/support/user-manuals
Note: These older Drake beltpacks are now obsolete. Please contact Clear-Com sales about trading up to the newer FreeSpeak beltpacks



Related Attachments
 None Found



  



Most popular solution: Hotfix for EHX failing to launch after .Net update.